mbox series

[v6,0/5] Allow better control over container tags

Message ID 20211215172550.27153-1-henning.schild@siemens.com
Headers show
Series Allow better control over container tags | expand

Message

Henning Schild Dec. 15, 2021, 7:25 a.m. UTC
changes since v5:

- allow to prepend a suffix so that one recipe can create multiple
  containers, i.e. the target and its sdk

changes since v4:

- one more rename of a variable we now use NAME[:TAG] and get
  CONTAINER_IMAGE_NAME, CONTAINER_IMAGE_TAG

changed since v3:

- only naming and docs
- rename variables again, patter is "class prefix"+"docker name"
  - docker calls the bits of a tag "TARGET_IMAGE[:TAG]"
  - prefix is "CONTAINER_IMAGE"
- also rename CONTAINER_FORMATS to CONTAINER_IMAGE_FORMATS in p4
- fix docs in p4

changes since v2:

- use CONTAINER_TARGET_IMAGE instead of CONTAINER_IMAGE_NAME
- update docs

changes since v1:

- add RECIPE-API-CHANGELOG entry for interface change in p3

--

A container tags consists of "name:tag" and both have been kind of
hardcoded so far. "tag" was always "latest" which is not proper
versioning. And "name" has always been "isar-DISTRO-ARCH" which is also
not proper because the name should probably describe the content and not
so much the build system. Plus that name means guaranteed collision if
you build two containers with isar based on the same disto and arch.


Henning Schild (5):
  classes: make sure container extension can run multiple times
  classes: simplify tag handling in container class
  classes: allow more control over container image name and tag
  classes: rename CONTAINER_FORMATS to CONTAINER_IMAGE_FORMATS
  classes: fix comment in container-img class

 RECIPE-API-CHANGELOG.md                       |  8 +++++
 doc/user_manual.md                            | 16 +++++-----
 meta/classes/container-img.bbclass            | 10 +++----
 .../classes/image-container-extension.bbclass | 30 ++++++++++---------
 meta/classes/image-sdk-extension.bbclass      |  2 +-
 5 files changed, 37 insertions(+), 29 deletions(-)

Comments

Anton Mikanovich Dec. 22, 2021, 5:27 a.m. UTC | #1
15.12.2021 20:25, Henning Schild wrote:
> changes since v5:
>
> - allow to prepend a suffix so that one recipe can create multiple
>    containers, i.e. the target and its sdk
>
> changes since v4:
>
> - one more rename of a variable we now use NAME[:TAG] and get
>    CONTAINER_IMAGE_NAME, CONTAINER_IMAGE_TAG
>
> changed since v3:
>
> - only naming and docs
> - rename variables again, patter is "class prefix"+"docker name"
>    - docker calls the bits of a tag "TARGET_IMAGE[:TAG]"
>    - prefix is "CONTAINER_IMAGE"
> - also rename CONTAINER_FORMATS to CONTAINER_IMAGE_FORMATS in p4
> - fix docs in p4
>
> changes since v2:
>
> - use CONTAINER_TARGET_IMAGE instead of CONTAINER_IMAGE_NAME
> - update docs
>
> changes since v1:
>
> - add RECIPE-API-CHANGELOG entry for interface change in p3

Applied to next, thanks.